Introduction

Welcome to Learn ASP.NET 4.0, C# and Visual Studio 2010 Essential Skills with The Smart Method. This book has
been designed to enable students to master essential ASP.NET skills by self-study. The book is equally useful
as courseware in the classroom.

Smart Method publications are continually evolving as we discover better ways of explaining or teaching the
concepts presented.

Feedback

At The Smart Method we love feedback - be it positive or negative. If you have any suggestions for
improvements to future versions of this book, or if you find content or typographical errors, the author
would always love to hear from you via e-mail to:

feedback@LearnASP4.com

Future editions will always incorporate your feedback so that there are never any known errors at time of
publication.

If you have any difficulty understanding or completing a lesson, or if you feel that anything could have been
more clearly explained, we’d also love to hear from you. We’ve made hundreds of detail improvements to
our books based upon reader’s feedback and continue to chase the impossible goal of 100% perfection!

Downloading the sample files

In order to use this book it is sometimes necessary to download sample files from the Internet. The sample
files are available from:

http://www.LearnASP4.com

Type the above URL into your web browser and you’ll see the link to the sample files at the top of the home
page.

Problem resolution

If you encounter any problem downloading or using the sample files please send an e-mail to:
feedback@LearnASP4.com

We'll do everything possible to quickly resolve the problem.
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Typographical Conventions Used In This
Book

This guide consistently uses typographical conventions to differentiate parts of the text.

When you see this Here’s what it means

Right-click on My Project in the Solution Explorer and Italics are used to refer to text that appears in a
then click Build from the shortcut menu. menu, a dialog, or elsewhere within the Visual

Studio application.

At times, italics may also be used for emphasis
or distinction.

Click File->New Project.... Click on the File menu and choose New
_ —r _ _ Project... from the drop-down menu.
File | Edit View Project Build Debug Data Tools
2 New Project... Ctrl+Shift+N
@ New Web Site... Shift+Alt+N
) NewFile... Ctrl+N
Click Edit>Outlining=> Click on the Edit menu and look for the

Collapse To Definitions. Outlining sub-menu. Click the Outlining menu

and then click on Collapse to Definitions.

Qutlining b Toggle Outlining Expansion Ctrl+M, Ctrl+M
IntelliSense - Toggle All Outlining Ctrl+M, Ctrl+L

' \ RegisterUser.Continuel Stop Outlining Ctrl+M, Ctrl+P
Stop Hiding Current Ctrl+M, Ctrl+U

= protected void RegisterUs¢ Collapse to Definitions Ctrl+M, Ctrl+0

Click Tools>Options...>Formatting—>

Server tag>Assembly definition. This is a more involved example.

Tools | Window  Help 1. Click the Tools menu, and then click the

¥4 Connectto Database... Options... button.

:-\] Code Snippets Manager... Ctrl+K, Ctrl+B .
Choose Toolbox Items... A new dlalog pops up

B Exension Manager... 2. Click on the Formatting group in the Options
External Tools... dialog.
Settings v 3. Drop down the Server Tag list and click
Customize... Assembly definition.
Options...

Type int X; on the next line. Whenever you are asked to actually type
something on the keyboard it is shown in bold
faced text.

Press <Ctrl> + <Z>. You should hold down the Ctrl key and then
press the Z key.
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Introduction

S When a lesson tells you to click a button, an
= image of the relevant button will often be
S shown either in the page margin or within the
2 text itself.

note

If you switch to Design view
and click on the properties of
an object in the Properties
window, you'll notice a short
description of the property...

If you want to read through the book as

quickly as possible, notes which usually
expand a little on the lesson text, may be
ignored.

important

Do not click the Delete button
at this point as to do so would
erase the entire table.

Whenever something can easily go wrong, or
when the subject text is particularly important,
you will see the important sidebar.

You should always read important sidebars.

tip
Moving between tabs
using the keyboard

You can also use <Ctrl>+<Tab>
on the keyboard to cycle
through all of the tabs you have
open.

Tips add to the lesson text by showing you
shortcuts or time-saving techniques relevant
to the lesson.

The bold text at the top of the tip box enables
you to establish whether the tip is appropriate
to your needs without reading all of the text.

In this example you may not be interested in
keyboard shortcuts so you do not need to read
further.

anecdote

I'worked on an ASP.NET
project for a gaming company a
couple of years ago...

Sometimes I add an anecdote gathered over
the years from my work or from other areas of
my experience.

If you simply want to learn ASP.NET as
quickly as possible, ignore anecdotes.

trivia
The Mosaic browser

Before 1993, the Internet
was very different to the
way it is today...

Sometimes I indulge myself by adding a little
piece of trivia in the context of the skill being
taught.

Just like my anecdotes you can ignore these if
you want to. They won’t help you to learn
ASP.NET any better!

If you are not completing the
course incrementally use the
sample file: Lesson 5-1

to begin this lesson.

When there is a sample file (or files) to
accompany a session, the file name will be
shown in a folder icon.

You can download the lesson or file from:
www.Learnasp4.com. Detailed instructions are
given in: Lesson 1-3: Set up the development
environment.

© 2011 The Smart Method Ltd
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Putting the Smart Method to Work

Visual Studio version and service pack

This edition was written using Visual Web Developer 2010 Express Service Pack 1 running under the Microsoft
Windows 7 Service Pack 1 operating system. You'll discover how to confirm that your computer is running
these versions during Lesson 1-2: Check your Visual Studio and Windows version.

If you are using an earlier operating system (for example Windows XP or Windows Vista) this book will be
equally relevant, but you may notice small differences in the appearance of some of the screen grabs in the
book. This will only occur when describing an operating system (rather than a Visual Studio) feature.

This book is written purely for Visual Studio 2010 Express and, due to changes in this version, some features
may not be available in earlier or later versions (such as 2005 and 2008).

Sessions and lessons

The book is arranged into Sessions and Lessons. In a Smart Method course a Session would generally last for
between forty-five and ninety minutes. Each Session would represent a continuous period of interactive
instruction followed by a coffee break of ten or fifteen minutes.

When this book is used for self-instruction I recommend that you do the same. You'll learn better if you lock
yourself away, switch off your telephone and complete the whole session without interruption. The memory
process is associative, and each lesson within each session is very closely coupled (contextually) with the
others. By learning the whole session in one sitting, you'll store all of that information in the same part of
your memory and should find it easier to recall later.

The experience of being able to remember all of the words of a song as soon as somebody has got you
“started” with the first line is an example of the memory’s associative system of data storage.

It is highly recommend that you do take a break between sessions and spend it relaxing rather than catching
up on your e-mails. This gives your brain a little idle time to do some data sorting and storage.

Read the book from beginning to end

Many books consist of disassociated self-contained chapters, often all written by different authors. This
approach works well for pure reference books (such as encyclopedias). The problem with this approach is
that there’s no concept of building knowledge upon assumed prior knowledge, so the text is either confusing
or unduly verbose as instructions for the same skill are repeated in many parts of the book.

This book is more effective as a learning tool because it takes a holistic approach. You will learn ASP.NET 4.0
in the same way you would be taught during one of our Smart Method courses.

In our classroom courses it’s often the case that a delegate turns up late. One golden rule is that we can’t
begin until everybody is present, as each hands-on lesson builds upon skills taught in the previous lesson.

I strongly recommend that you read the book from beginning to end in the order in which it is written.
Because of the unique presentational style, you'll hardly waste any time reading about things that you
already know and even the most advanced ASP.NET developer will find some nugget of extremely useful
information in every session.

1 6 www.LearnASP4.com
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How this book avoids wasting your time

Nobody has things just as he would like them. The thing to do is to make a success with what material I
have.

Dr. Frank Crane (1861-1928), American clergyman and journalist

The only material available to me in teaching you ASP.NET is the written word and sample files. I'd rather
have you sitting next to me in a classroom, but Frank Crane would have told me to stop complaining and
use the tools I have in the most effective way.

Over the years I have read many hundreds of computer text books. Most of my time was wasted. The main
problem with most books is having to wade through thousands of words just to learn one important
technique. Not reading everything could mean missing that one essential insight.

This book utilizes some of the tried and tested techniques developed after teaching vast numbers of people
during many years of delivering Smart Method classroom courses.

As you'll see in this section, many presentational methods are used to help you to avoid reading about
things you already know, or things that are of little interest.

Why our classroom courses work so well

In our classroom courses we don’t waste time teaching skills that the delegates already know. If it is clear
that the delegate already understands a skill no time is wasted explaining it, but if the delegate has difficulty,
more information is given until success is demonstrated.

Another key to learning effectively is to teach only the best way to accomplish a task. For example, you can
comment code by typing two forward slashes or you can click the shortcut buttons on the toolbar. Because
typing forward slashes is the easiest, fastest and most intuitive method, only this is practised in the
classroom. In the book we do mention the alternatives, but only in a sidebar.

How this book mimics our classroom technique

Here’s a lesson step:

1 Add a basic comment.

tl p 1. Add anew line before:

Comment shortcuts return RoundNumber(FirstNumber + SecondNumber);
using the toolbar 2. Add a comment with the code:

You can quickly comment //Add FirstNumber and SecondNumber

and uncomment code using You'll see that the comment is shown in green.

the comment buttons on the
toolbar:

o)

If you already know how to add a comment, read only the line: Add a basic comment and just do it. Don’t
waste your time reading anything else.

Read the smaller print only when the information is new to you.

© 2011 The Smart Method Ltd 17
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If you're in a hurry to learn only the essentials, as fast as possible, don’t bother with the sidebars unless they
are labeled important.

Read the sidebars only when you want not to miss anything and have the time and interest.

Avoiding repetition

2  Open the code-behind file of default.aspx.

You learned how to do this in: Lesson 1-7: Manage a project with the
Solution Explorer.

In this book (and in our classroom courses) we do not wish to waste your time with reiteration.

In a classroom course, a delegate will sometimes forget something that has already been covered that day.
The instructor must then try to get the student to remember and drop little hints reminding them about how
they completed the task earlier.

This isn’t possible in a book, so I've made extensive use of cross references in the text pointing you back to
the lesson in which the relevant skill was learned. The cross references also help when you use this book as a
reference work but have forgotten the more basic skills needed to complete each step.

Use of American English

American English (rather than British English) spelling has been used throughout. This is because the help
system and screen elements all use American English spelling, making the use of British English confusing.

Examples of differences are the British English spelling: Colour and Dialogue as opposed to the American
English spelling: Color and Dialog.

Because this book is available worldwide, much care has been taken to avoid any country-specific
terminology. For example, in most of the English speaking world, apart from North America, the symbol # is
referred to as the hash sign, so the term hash is used throughout this book.

1 8 www.LearnASP4.com
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First page of a session

1/ The first page begins witha ————

quotation, often from an era
before the age of the computer,
that is particularly pertinent to
the session material. As well as
being fun, this helps us to
remember that all of the real-
world problems we solve with
technology have been around
for a long time.

3/ The session objectives
formally state the precise skills
that you will learn in the
session.

~

At the end of the session you
should re-visit the objectives
and not progress to the next
session until you can honestly
agree that you have achieved
them.

In a Smart Method course we

never progress to the next

I\

Sesniont

Session One: The Sample
Database

Session Objectives

e wiae

session until all delegates are
completely confident that they
have achieved the previous
session’s objectives.

2/ In the next few paragraphs
we informally summarise why
the session is important and the
benefits that can be gained.

This is important because
without motivation adults do
not learn. For adults, learning is
a means to an end and not an
end in itself.

The aim of the introduction is
to motivate your retention of
the skills that will be taught in
the following session by
allowing you to preview the
relevance of the material that
will be presented. This may
subconsciously put your brain
into “must remember this”
mode —assuming, of course,
that the introduction convinces
you that the skills will be useful
to you!

© 2011 The Smart Method Ltd
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Every lesson is presented on two facing pages

Pray this day, on one side of one sheet of paper, explain how the Royal Navy is prepared to meet the
coming conflict.
Winston Churchill, Letter to the Admiralty, Sep 1, 1939

Winston Churchill was well aware of the power of brevity. The discipline of condensing thoughts into one
side of a single sheet of A4 paper resulted in the efficient transfer of information.

A tenet of our teaching system is that every lesson is presented on two facing sheets of A4. We’ve had to
double Churchill’s rule as they didn’t have to contend with screen grabs in 1939!

If we can’t teach an essential concept in two pages of A4 we know that the subject matter needs to be broken
into two smaller lessons.

Tips, important information and
notes appear in sidebars.

Each step is numbered and begins with
the thing you need to do in bold type.
Sometimes this is all you need to read

to accomplish the task.

Step notes sometimes provide precise
instructions on how to progress if the —_|
one-line description is inadequate.

Notes often also include interesting
information about the current task.

If you are not working through the

course sequentially, a file is

available on our web site that

contains the starting point for

every lesson. The file name you

need to download is stated in the \
file icon at bottom left of every

lesson page.

Leamn Access VBA 2003 with The Smart Method

tip

Some of The Smart
Method'’s rules for
table names and
relationships:

™. 1/ Table names are always in
the singular and never in the
plural.

2/ The primary key is always
meaningless (ie autonumber
data type) and is named using
the syntax: <table name> + <ID>

3/ Foreign keys always have
exactly the same name as the
related Primary key (for
example the primary key
MedialD in the Media table is
also called MedialD in the Film
table.

are listed in Appendix A: The
Rudes.

\ "
Session1

5/ The link table in a many-to-
jonship is always
named with t the
tables on either side of the 5
many to many relationship (for
el FilmActor "b; : Note the relationships between the tables. It is often useful to read
: oy the relationships to a client from the schema to ensure that they are
All of these nules (and others) correct. For example:-

Lesson 1-1: Understand the
sample database

The sample database will manage a collection of films. The schema
incorporates some of The Smart Method's preferred naming conventions
and design rules.

1 Create a new folder for your application on the C:\ drive
called C:\FilmLibrary.

2 Download the FilmLibrary-Session1.zip file from
http:/www.thesmarntmethod.com/ccess_VBA_Sample_Files
save it to this location, unzip it and then re-name it
FilmLibrary.mdb.

3 Open the FilmLibrary, mdb database

4 Select Tools=>Relationships from the main menu to view the
schema.

The schema is displayed

Understand the table relationships.

“One film may have one and only one director but a director may
direct many films.” (A one to many relationship).

"One film may have many actors and one actor may perform in
many films.” (A many to many relationship)

6 Understand the relationship types.

Right-click on the relationship between the Film and Director
tables and choose Edit Relationship... from the shortcut menu. The
Edit Relationship dialogue is displayed.

18
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Learning by participation

Tell me, and I will forget. Show me, and I may remember. Involve me, and I will understand.

Confucius (551-479 BC)

Confucius would probably have agreed that the best way to teach IT skills is hands-on (actively) and not
hands-off (passively). This is another of the principal tenets of the Smart Method teaching system. Research
has backed up the assertion that you will learn more material, learn more quickly, and understand more of
what you learn, if you learn using active, rather than passive methods.

For this reason pure theory pages are kept to an absolute minimum with most theory woven into the hands-
on sessions either within the text or in sidebars. This echoes the teaching method in Smart Method courses,
where snippets of pertinent theory are woven into the lessons themselves so that interest and attention is
maintained by hands-on involvement, but all necessary theory is still covered.

Session One: The Sample Database

important

Amateur database designers
often leave their databases
open to corruption by not
enforcing referential integrity
between their tables.

The usual excuse for not
enforcing referential integrity is
that it will stop users entering
incomplete records (for
example users may wish to
create a Film record when the
Director name is not known).

The simple solution to this
problem is to make sure that
the default value of the foreign
key within the parent table (the
Director]D field within the Film
table) is always Null (Null
means the absence of any value
at all). It will then be possible to
create Film records when the
Director is not known.

note

You might wonder what
would happen if you checked
the Cascade Update Related Frelds
check box

If you follow our design rules
all primary keys will be
meaningless (see tip sidebar
and Appendix-A: The Rules),
Amateur database designers
(and even ones that have
simply read the wrong books!)
often create meaningful
primary keys causing all sorts
of problems.

Cascade Update Related Fields
is simply a work around for
one of the problems caused by
breaking this design nile - the
case when a meaningful
primary key must be changed
and propagated throughout the
entire database.

In a properly designed
database you'll never have to
use this option.

Edit Relationships ? rgl
Table/Query: Related Table Query:

Drrect ¥ Fim

DrectorlD N DrectorlD ~

Jom Type

[ Enforce Referental integrity]
[[cascade Undate Related Fields
[[]Cascade Deiste Related Records

Relatonshp Type: One-To-Many

Note the Enforce Referential Integrity check box. This means that if a
user attempts to delete a director who is attached to any films the
delete will fail.

1t is vitally important to enforce referential integrity for all
relationships within your database. Access does not do this by
default!

Understand when to use Cascade Delete.

Close the Edit Relationships dialogue. Right-click on the
relationship between the Film and Film Actor tables and choose
Edit Relationship... from the shortcut menu. The Edit Relationship
dialogue is displayed.

Edit Relationships

RQelatad Table/Query:
Eom | Fimactor -

FimID | FmD -

[ZlEnforce Referent
D Cascade |Jpdate Related Fieids
[¥]Cascade Detete Related Records

Relationship Type: One-To-Many

Note that the Cascade Delete Related Records check box is
checked

This is one of the rare examples when Cascade Delete Related
Records makes sense because we would want to automatically
delete the association between a film and it's actors in the event
that the user wanted to delete a film record.

www.thesmartmethod.com
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Screen grabs are provided in-line with the
| text when they can explain what you
need to do more clearly than words
alone.

© 2011 The Smart Method Ltd
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